Internet dropping out in bridge mode

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
16 messages Options
Reply | Threaded
Open this post in threaded view
|

Internet dropping out in bridge mode

user8446
Administrator
This post was updated on .
Right before the forums went down there was a thread about an issue in bridge mode where the internet would drop out and then return. The syslog on their boxes showed snort restarting but the IPS log showed no rules firing. A member had investigated and found a rule that was causing the restart and Itus removed it but people we're still experiencing the issue so there must be more rules doing this. Anyone else have this issue? I'm still seeing this on mine.
Running in bridge mode, 1.51 SP1 fw
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

jeffs123
I was experiencing this issue (kohls.com at first which was traced back to akamai if I'm not mistaken, and then it turned into seemingly random snort crashes) and have since removed the Shield from sitting between my modem and router.  I still have it running to get updates and will add it back to the mix to see if I'm still having the issue later this week.
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

Wisiwyg
I was one having this problem. But, I've since implemented a nightly reboot, just after the IPS signature update runs and haven't seen this to be much of an issue as late.

This may be that I'm not seeing it as it burbs and then recovers, but it as been less of an issue for me.
Shield Pro v1, Chaos Calmer, FW 1.51 SP1, v8.3.2, Bridge Mode
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

Wisiwyg
OK, I can confirm that this still happens...

I have been working from home for the last few days due to holidays and kids out of school. Yesterday I can identify at least 3 instances when internet dropped for about 3-5 minutes and came back up, consistent with Snort restarting. I was in the middle of things yesterday, but I'll try to capture the log the next time it happens to see if there is something we can pinpoint.
Shield Pro v1, Chaos Calmer, FW 1.51 SP1, v8.3.2, Bridge Mode
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

Oilman
I get this also, but it normally appears when I have a big continuous download or streaming a movie, but not all the time, so it appears to happen when it is under load, not at maximum, but not just low load.  In looking at the logs the snort just reloads. Initially I thought maybe the device is getting too hot, so I put a fan on the device to cool it down, but it still happened so that does not appear to be the problem. Still trying to get more data to be able to determine the issue.  I have all the hotfixes to 8.3
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

Turrican
Did anyone come to any conclusions about this?  my Shield is up to date (as far as march hotfix) but every few days I notice the internet drops for a few mins, when I check Shield the memory usage is high (maybe about 50-60%).  Just wondering if there's any theory's?  it could be a show stopper as my wife works from home and relies on a good internet connection.

Thanks all

Running Bridge Mode
v1.51 SP1 + Hotfix Mar 9
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

Wisiwyg
This still occasionally happens, but I don't get into Shield to examine the logs to see if it burped.

Increasing the available memory and forcing a reboot after each nightly signature update has pretty much made it a non-issue for me. My wife and I also work from home frequently. If it goes down, it is back up in about a minute. Like its Snort that is restarting, not the whole system.
Shield Pro v1, Chaos Calmer, FW 1.51 SP1, v8.3.2, Bridge Mode
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

user8446
Administrator
In the snort config did you guys do the IPS log fix (have mine set to 64k) which will slow speeds and reboot snort if it gets too big and the stream processor fix which if you are streaming a big file it will pause and restart. I have my max_queued_bytes @ 1110032 and prune_log_max @ 1168334. I last had my box on for over 90 days straight and only rebooted manually because I'm trying to work out a different bug on the network.
Running in bridge mode, 1.51 SP1 fw
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

Turrican
I did the IPS log fix to 64k as you mentioned in a previous thread.  I also clear the log every night at 3am.

When this happens again, would it be useful to post my system log here?

Thinking of going the Pfsense+snort route but would rather keep the Shield as it's an elegant solution.

Thanks

Running Bridge Mode
v1.51 SP1 + Hotfix Mar 9
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

user8446
Administrator
Did you do the other 2 fixes?
Yes, posting the log will help. We're looking for "S5: Pruned session from cache" and "S5: Session exceeded configured max bytes to queue"
Running in bridge mode, 1.51 SP1 fw
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

Turrican
Hi, no didn't do the other 2 fixes, can't seem to locate that info, can you please remind me?

I'm getting this in my log:

Fri Jul 15 07:21:22 2016 daemon.notice snort[20150]: S5: Session exceeded configured max bytes to queue 1048576 using 1049356 bytes (client queue). 86.xx.xx.xx 49666 --> 13.107.4.50 80 (0) : LWstate 0x9 LWFlags 0x406007
Fri Jul 15 08:25:11 2016 daemon.notice snort[20150]: S5: Pruned session from cache that was using 1104419 bytes (stale/timeout). 86.xx.xx.xx.xx 49666 --> 13.107.4.50 80 (0) : LWstate 0x9 LWFlags 0x6007
Fri Jul 15 18:38:31 2016 daemon.notice snort[20150]: S5: Session exceeded configured max bytes to queue 1048576 using 1049952 bytes (client queue). 86.xx.xx.xx 49809 --> 13.107.4.50 80 (0) : LWstate 0x9 LWFlags 0x406007
Fri Jul 15 19:44:21 2016 daemon.notice snort[20150]: S5: Pruned session from cache that was using 1104936 bytes (stale/timeout). 86.xx.xx.xx.xx 49809 --> 13.107.4.50 80 (0) : LWstate 0x9 LWFlags 0x6007

Thanks, running Bridge mode in case that helps.

Running Bridge Mode
v1.51 SP1 + Hotfix Mar 9
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

user8446
Administrator
The easiest way is to go to services > intrusion prevention > snort config and find these two sections and replace with the following:

preprocessor stream5_global: track_tcp yes, \
   track_udp yes, \
   track_icmp yes, \
   max_tcp 10000, \
   max_udp 10000, \
   max_active_responses 2, \
   min_response_seconds 5, \
   prune_log_max 1170355

preprocessor stream5_tcp: policy windows, detect_anomalies, require_3whs 180, \
   overlap_limit 10, small_segments 3 bytes 150, timeout 180, \
   max_queued_bytes 1112290, \
    ports client 21 22 23 25 42 53 70 79 109 110 111 113 119 135 136 137 139 143 \
        161 445 513 514 587 593 691 1433 1521 1741 2100 3306 6070 6665 6666 6667 6668 6669 \
        7000 8181 32770 32771 32772 32773 32774 32775 32776 32777 32778 32779, \
    ports both 36 80 81 82 83 84 85 86 87 88 89 90 110 311 383 443 465 563 555 591 593 631 636 801 808 818 901 972 989 992 993 994 995 1158 1220 1414 1533 1741 1830 1942 2231 2301 2381 2809 2980 3029 3037 3057 3128 3443 3702 4000 4343 4848 5000 5117 5250 5600 6080 6173 6988 7907 7000 7001 7071 7144 7145 7510 7802 7770 7777 7778 7779 \
        7801 7900 7901 7902 7903 7904 7905 7906 7908 7909 7910 7911 7912 7913 7914 7915 7916 \
        7917 7918 7919 7920 8000 8008 8014 8028 8080 8081 8082 8085 8088 8090 8118 8123 8180 8181 8222 8243 8280 8300 8333 8344 8500 8509 8800 8888 8899 8983 9000 9060 9080 9090 9091 9111 9290 9443 9999 10000 11371 12601 13014 15489 29991 33300 34412 34443 34444 41080 44449 50000 50002 51423 53331 55252 55555 56712
preprocessor stream5_udp: timeout 180



just copy and paste then "save and apply". Snort will restart. If you have a lot of devices on your network we might have to raise those values slightly.
Running in bridge mode, 1.51 SP1 fw
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

Turrican
Thank you.

Running Bridge Mode
v1.51 SP1 + Hotfix Mar 9
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

Turrican
Still getting random snort reboots causing internet to drop which has forced me to dissconnect the shield.

Hoping someone can find a resolution to this - is everyone else in Bridge mode experiencing this?

Have tried all the suggestions previously mentioned. As my wife works from home and spends most of the day on webex or hangout calls, it's not great, hence it'll stay offline for now.

Anyone wanna buy a Shield (UK?)

cheers

Running Bridge Mode
v1.51 SP1 + Hotfix Mar 9
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

Roadrunnere42
I Had this problem only in bridge mode, in router mode the Shield is now rock steady with the latest fixes,

I tried loads of stuff but could not get to the bottom of it, but if i left the Shield alone it seemed to behave itself but if I logged into the shield  via website It would then start to restart snort at random times, but i now only  us the shield in router modes and am surprised at the stuff that is coming through my virgin media router with the firewall turned on.

Roadrunnere42
Reply | Threaded
Open this post in threaded view
|

Re: Internet dropping out in bridge mode

Turrican
Interesting, can you PM me your setup from the virgin media router please? Are you running it in router or bridge mode?

Thanks

Running Bridge Mode
v1.51 SP1 + Hotfix Mar 9